发新贴  快速回复

为什么引入semantic.css会报错呢,不引入就没事

  shenlj
2017-11-14 18:25

本帖内容针对以下视频发布:

1-组件
 
Flowke

 需要配置好 loader 处理字体, 请问你是我的配置么还是 create-react-app

2017-11-16 19:09  回复本帖
 
熊小鱼

Flowke 2017-11-16 19:09发表的内容:

 需要配置好 loader 处理字体, 请问你是我的配置么还是 create-react-app

老师你好我也有相同引入css报错 ,用的你的配置,npm install semantic-ui --save
cd semantic/
gulp build
创建的semantic
ERROR in ./~/css-loader!./semantic/dist/semantic.css
Module not found: Error: Can't resolve 'file-loader' in 'F:\ff'
@ ./~/css-loader!./semantic/dist/semantic.css 6:170920-170970 6:170993-171043
@ ./semantic/dist/semantic.css

webpack.config.js都是复制你的
package.jion 我添加了2个生产依赖 npm init
2017-11-28 19:47  回复本帖
 
Flowke

 能把你负责的 webpack.config.js的配置看一下么, 配置里少了file-loader 对字体处理。 你可以从课程资料里找到 《从2.1-2.6的课程代码》里面有相应源代码, 这是我前段时间整理过的。

2017-11-29 10:58  回复本帖
 
熊小鱼

const path = require('path');

const webpack = require('webpack');

const HtmlWebpackPlugin = require('html-webpack-plugin');

module.exports = {

entry: [

'./src/app.js'

],



output: {

filename: 'main.js',

path: path.resolve(__dirname, 'dist/assets'),

publicPath: '/assets/'

},



module: {

rules: [

{

test: /\.js$/,

use: ['babel-loader'],

include:[

path.resolve(__dirname, './src')

]

},

{

test: /\.css$/,

use: ['style-loader','css-loader']

},

{

test: /\.(png|jpg|jpeg|gif)$/,

use: ['url-loader?limit=8192'],

},

{

test: /\.(mp4|ogg|svg)$/,

use: ['file-loader']

},

{

test: /\.(woff|woff2)(\?v=\d+\.\d+\.\d+)?$/,

use: ['url-loader?limit=10000&mimetype=application/font-woff']

},

{

test: /\.ttf(\?v=\d+\.\d+\.\d+)?$/,

use: ['url-loader?limit=10000&mimetype=application/octet-stream']

},

{

test: /\.eot(\?v=\d+\.\d+\.\d+)?$/,

use: ['file-loader']

},

{

test: /\.svg(\?v=\d+\.\d+\.\d+)?$/,

use: ['url-loader?limit=10000&mimetype=image/svg+xml']

}

]

},



plugins: [

new webpack.HotModuleReplacementPlugin(),

new HtmlWebpackPlugin({

filename: '../in.html',

template: './src/index.html'

})

],



devtool: 'cheap-module-eval-source-map'




}

这是我的webpack.config.js文件 请问下老师这个是不是{

 

test: /\.eot(\?v=\d+\.\d+\.\d+)?$/,

 

use: ['file-loader']

 

},字体处理配置文件
 
 

 

老师你好,在项目中package.josn文件中我怎么能确定能用到那些依赖呢
附件下载:
 
2017-11-29 17:26  回复本帖
登录 后才可以发表回复