发新贴  快速回复

配置webpack.dev.conf.js,然后npm run dev就报错:

  若比邻
2017-11-15 17:28

请问老师,按照教程里所示,配置webpack.dev.conf.js,然后npm run dev就报错:

npm ERR! code ELIFECYCLE

npm ERR! errno 1

npm ERR! 163@1.0.0 dev: `webpack-dev-server --inline --progress --config build/webpack.dev.conf.js`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the 163@1.0.0 dev script.

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

 

npm ERR! A complete log of this run can be found in:

npm ERR!     /Users/admin/.npm/_logs/2017-11-15T09_19_06_673Z-debug.log

请问是什么原因

本帖内容针对以下视频发布:

3.ViewBox,xHeader,Tabbar,TabbarItem
 
若比邻

还有就是我的这个文件跟你的不一样。

2017-11-15 17:30  回复本帖
 
zmouse

错误没发完整吧?全部错误提示是什么?

2017-11-16 16:06  回复本帖
 
若比邻

在 webpack.dev.conf.js 里添加


const VuxLoader = require('vux-loader');


baseWebpackConfig = VuxLoader.merge(baseWebpackConfig, {


  plugins: ['vux-ui']


})


 


就报如下错误:

2017-11-17 16:52  回复本帖
《神仙未来》*3

仔细研读vux官网就会明白了。


应该在build/webpack.base.conf.js里面做3步修改即可


首先


const vuxLoader = require('vux-loader')
然后,只要把原来的 module.exports = 换成const webpackConfig = const webpackConfig = originalConfig 最后,添加下面的代码 module.exports = vuxLoader.merge(webpackConfig, { plugins: ['vux-ui'] })                           

2017-11-17 23:44  回复本帖
 
mmzuo

若比邻 2017-11-17 16:52发表的内容:

在 webpack.dev.conf.js 里添加


const VuxLoader = require('vux-loader');


baseWebpackConfig = VuxLoader.merge(baseWebpackConfig, {


  plugins: ['vux-ui']


})


 


就报如下错误:

我的跟你报一样的错误,请问你解决了吗?什么原因导致的
2017-11-19 08:26  回复本帖
 
mmzuo

若比邻 2017-11-17 16:52发表的内容:

在 webpack.dev.conf.js 里添加


const VuxLoader = require('vux-loader');


baseWebpackConfig = VuxLoader.merge(baseWebpackConfig, {


  plugins: ['vux-ui']


})


 


就报如下错误:

assignment to constant variable 恒定的变量分配的报错
这里把const baseWebpackConfig修改成 let 来定义变量就可以修改baseWebpackConfig的值了
2017-11-19 08:55  回复本帖
登录 后才可以发表回复